Service Disruption

Incident Report for Crossbeam

Resolved

Services recovered as of 6pm US Eastern yesterday. We have not yet determined the root cause of the outage. We shall continue to investigate and monitor.
Posted Apr 30, 2024 - 11:23 EDT

Update

Services have recovered. We shall continue to investigate and monitor.
Posted Apr 29, 2024 - 18:00 EDT

Update

Services are recovering however we are continuing to investigate and monitor.
Posted Apr 29, 2024 - 17:39 EDT

Investigating

Our team continues to investigate an issue that is causing sitewide disruption to the Crossbeam application. We will provide updates as they become available.
Posted Apr 29, 2024 - 16:54 EDT
This incident affected: Web App (app.crossbeam.com), API (api.crossbeam.com), Background Processing, Crossbeam for Sales (web), and Crossbeam for Sales (API).