Service Disruption
Incident Report for Crossbeam
Resolved
This incident has been resolved.
Posted Apr 29, 2024 - 16:27 EDT
Monitoring
The application is back online, and we will continue to monitor the system throughout the day.
Posted Apr 29, 2024 - 13:11 EDT
Update
We are continuing to investigate this issue.
Posted Apr 29, 2024 - 12:46 EDT
Investigating
Our team is currently investigating an issue that is causing sitewide disruption to the Crossbeam application. We will provide updates as they become available.
Posted Apr 29, 2024 - 12:44 EDT
This incident affected: Web App (app.crossbeam.com), API (api.crossbeam.com), Background Processing, Crossbeam for Sales (web), and Crossbeam for Sales (API).