The web app and background jobs should now be functioning as normal.
The root cause was a regression in the migration library our backend uses that caused an inadvertent drop of our operational schema. We have rolled back the version of this library and introduced additional measures to defend from this situation in the future. Thank you for your patience!
Posted Oct 28, 2022 - 13:09 EDT
Monitoring
Crossbeam should be coming back online. We are monitoring the operational database and resolving any background processing.
Posted Oct 28, 2022 - 12:39 EDT
Identified
We have identified the cause of the outage. We are working to restore one of our operational databases before the incident. We will be monitoring as we come back online.
Posted Oct 28, 2022 - 12:24 EDT
Investigating
The Crossbeam backend is currently experiencing an outage. We are investigating the root cause and will provide updates regularly as we find the root cause.
Posted Oct 28, 2022 - 12:15 EDT
This incident affected: Web App (app.crossbeam.com), API (api.crossbeam.com), and Background Processing.