API Performance Degraded

Incident Report for Crossbeam

Resolved

This incident has been resolved.
Posted Aug 02, 2022 - 13:42 EDT

Monitoring

We have identified the cause of this performance issue, deployed a fix and are monitoring system performance.
Posted Aug 02, 2022 - 12:12 EDT

Investigating

We are experiencing intermittent outages due to backend issues. Our engineering team is currently investigating, and we will be posting regular updates.
Posted Aug 02, 2022 - 12:00 EDT
This incident affected: Web App (app.crossbeam.com) and API (api.crossbeam.com).