AWS incident impacting crossbeam services.
Incident Report for Crossbeam
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 17:21 EDT
Monitoring
We are currently tracking an issue with Amazon Web Services that may have performance and availability impacts to our service.
Posted Jun 13, 2023 - 15:22 EDT
This incident affected: Web App (app.crossbeam.com), API (api.crossbeam.com), Background Processing, Crossbeam for Sales (web), and Crossbeam for Sales (API).