Crossbeam API availability and performance

Incident Report for Crossbeam

Resolved

This incident has been resolved.
Posted Jun 01, 2023 - 08:57 EDT

Monitoring

We have tuned resource limits in our production cluster and API responses are now operating within normal ranges. We will continue to closely monitor performance and availability.
Posted May 31, 2023 - 14:46 EDT

Investigating

Starting at around 10:45AM US/East we experienced some interruptions to the availability of the crossbeam backend APIs and decreased overall performance we are continuing to investigate cause.
Posted May 31, 2023 - 11:38 EDT
This incident affected: Web App (app.crossbeam.com) and API (api.crossbeam.com).