Issues with HubSpot data syncs

Incident Report for Crossbeam

Resolved

All HubSpot data syncs have been re-enabled and are operating normally.
Posted Apr 29, 2022 - 13:41 EDT

Update

HubSpot informed us that they were having issues with their Cloudflare servers inadvertently rate limiting users, and Crossbeam was affected. It should be resolved today, and we will be re-enabling HubSpot data syncs and closely monitoring them. Thank you for your patience!
Posted Apr 29, 2022 - 09:20 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 28, 2022 - 15:33 EDT

Monitoring

Our team has uncovered some unclear rate limiting that started occurring with the HubSpot API this morning around 9:24am ET. We have paused our HubSpot data syncs through tomorrow to allow it to reset. We will be monitoring our data syncs tomorrow as we bring them back online. Thank you for your patience.
Posted Apr 28, 2022 - 15:12 EDT

Update

Our team has identified an issue with rate limits against the HubSpot API and are working towards a solution. In the interim, we have paused HubSpot data syncs for users that were affected. We will provide an update once we have a solution in place.
Posted Apr 28, 2022 - 13:12 EDT

Identified

Our team has identified an issue with our incoming HubSpot data syncs. If you connected your HubSpot CRM into Crossbeam, you are most likely affected. We've identified a root cause and are working towards a solution. We will be providing updates as we progress. Apologies for the inconvenience!
Posted Apr 28, 2022 - 11:53 EDT
This incident affected: Background Processing.