Active users not able to access their organization.

Incident Report for Crossbeam

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 21:36 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2025 - 19:22 EDT

Update

We are continuing to investigate this issue.
Posted Apr 23, 2025 - 19:22 EDT

Investigating

We are currently investigating this issue.
Posted Apr 23, 2025 - 18:23 EDT
This incident affected: Web App (app.crossbeam.com).